Siga-nos em...
Follow us on Twitter Follow us on Facebook Watch us on YouTube
Registro


HGIDC
Resultados 1 a 6 de 6
  1. #1

    Avatar de TheNight
    Data de Ingresso
    May 2014
    Localização
    no computador
    Posts
    94
    Agradecido
    15
    Agradeceu
    11
    Peso da Avaliação
    4

    Padrão vB | Versões: PHP | Apache | MySQL qual usar?

    Galera tenho a seguinte dúvidas, primeiro peço pra quem tenha link de download de algum programa que rode vBulletin em localhost perfeitamente, poste por favor.

    Seguinte no site oficial do vBulletin diz que as configurações recomendadas para rodar vB 4.2.2 são essas:

    Requisitos Mínimos

    Informação

    PHP versão 5.2.0 ou superior - Para PHP 5.4 ou superior, você deve usar vBulletin 4.2.2 ou superior.
    MySQL versão 4.1.0 ou superior
    Um nome de domínio pré-inscritos
    200 megabytes de espaço em disco rígido
    A maioria dos provedores de hospedagem já tem esses aplicativos em seus servidores. Com os requisitos acima quis dizer, o software vBulletin será executado em qualquer sistema operacional usando qualquer software de servidor web moderna.


    Diz requisitos mínimos e o máximo qual seria?

    Bom destaquei as minhas dúvidas com cores diferentes e/ou negrito, mas galera eu não preciso usar a versão do php5.2.0 a versão exata seria essa, mas ali diz que posso usar php 5.4, alguém já testou? pois pelos meus testes, php 5.4 da um erro de duplicate key ao criar posts no forum ou posso usar php5.4 e apenas alterar a versão do mysql ?

    Espero que me ajudem?
    "Ame a vida e os bons amigos, pois a vida é curta e os bons amigos são poucos."

  2. #2



    Avatar de Erick-Master
    Data de Ingresso
    Jul 2010
    Localização
    Lorencia :D
    Posts
    401
    Agradecido
    428
    Agradeceu
    152
    Peso da Avaliação
    16

    Padrão

    Não existe requisito máximo.
    Em base das versões compatíveis com PHP 5.4, você poderá usar até o PHP 5.6.

    Para você entender essas diferenças entre um PHP e o outro.
    Quando uma aplicação que exige uma versão antiga do PHP, como o 5.2 por exemplo, o que a torna compatível com as versões mais novas é apenas o fato de eles não utilizarem métodos e funções obsoletas das atuais versões.
    Nos guias de atualização do PHP lista todas as alterações entre um PHP e o outro.
    Agora, quando uma aplicação exige uma versão mínima, como por exemplo o PHP 5.3 que é significativamente a "abertura" ao novo método de programação do PHP, é pelo simples fato de terem mudado praticamente toda a base interna do sistema, fazendo um melhor uso do POO (Programação Orientada a Objeto), que, inicialmente no PHP 5.3 e fortemente adaptado no PHP 5.4, dá origem a forma correta e para alguns, "avançada", de programar em POO, no caso, fazendo uso das mesmas regras utilizadas em linguagens mais robustas em POO, como C# e Java, linguagens inteiramente em objeto.

    Hoje em dia, tem certos casos que até consideramos certos códigos em PHP porcos apenas pela forma como foi idealizado.
    PHP 4 mesmo é considerado porco até mesmo para Rasmus Lerdorf, criador do PHP.
    Eu, particularmente, não acho nada legal aplicações programas em PHP 5.2, pois o que o PHP 5.3, 5.4 e 5.5 tem a oferecer é incrível, fora os códigos lindos.

    Espero ter esclarecido suas dúvidas em relação a essas versões do PHP.
    Segue abaixo alguns links com guias de migração entre um PHP e o outro (para programadores), só para você entender melhor:

    • [Somente usuários registrados podem vem os links. ]
    • [Somente usuários registrados podem vem os links. ]
    • [Somente usuários registrados podem vem os links. ]
    • [Somente usuários registrados podem vem os links. ]

    []'s

  3. O Seguinte Usuário Agradeceu Erick-Master Por este Post Útil:


  4. #3

    Avatar de TheNight
    Data de Ingresso
    May 2014
    Localização
    no computador
    Posts
    94
    Agradecido
    15
    Agradeceu
    11
    Peso da Avaliação
    4

    Padrão

    O problema é que se eu usar outras versões do php no vbulletin ele me retorna erro de "duplicate key" na db....

    Já tentei usar outras versões mas á que me sai mais bem é o php5.2.17 agora não sei se o que faz isso é o php ou o mysql :/
    "Ame a vida e os bons amigos, pois a vida é curta e os bons amigos são poucos."

  5. #4



    Avatar de Erick-Master
    Data de Ingresso
    Jul 2010
    Localização
    Lorencia :D
    Posts
    401
    Agradecido
    428
    Agradeceu
    152
    Peso da Avaliação
    16

    Padrão

    Esse "duplicate key" é devido alguma referência inválida no seu banco de dados.
    As vezes ele tenta inserir algum dado utilizando uma chave primária (primary key ou ID) que já existe na tabela.
    Tenta descobrir qual a tabela que retorna esse erro....

    []'s

  6. #5

    Avatar de TheNight
    Data de Ingresso
    May 2014
    Localização
    no computador
    Posts
    94
    Agradecido
    15
    Agradeceu
    11
    Peso da Avaliação
    4

    Padrão

    post_log que eu me lembro...
    "Ame a vida e os bons amigos, pois a vida é curta e os bons amigos são poucos."

  7. #6



    Avatar de Erick-Master
    Data de Ingresso
    Jul 2010
    Localização
    Lorencia :D
    Posts
    401
    Agradecido
    428
    Agradeceu
    152
    Peso da Avaliação
    16

    Padrão

    Então experimenta limpar os valores dessa tabela (não esqueça de fazer backup do banco de dados).

    []'s

  8. O Seguinte Usuário Agradeceu Erick-Master Por este Post Útil:


 

 

Informações de Tópico

Usuários Navegando neste Tópico

Há 1 usuários navegando neste tópico. (0 registrados e 1 visitantes)

Tópicos Similares

  1. Qual MS usar MuEmu ou Ferrarezi?
    Por -SNOOP- no fórum Cantinho IMP Games
    Respostas: 6
    Último Post: 29-04-2016, 11:03 AM
  2. |Dúvida| Qual VPS usar para um Servidor de MuOnline 97d
    Por ronne no fórum Dúvidas
    Respostas: 2
    Último Post: 08-09-2015, 01:17 PM
  3. |Dúvida| Qual Ant hacker Usar
    Por mutroia no fórum Pedidos
    Respostas: 5
    Último Post: 20-08-2014, 02:54 AM
  4. |Dúvida| Qual segurança usar em um server 97d ?
    Por William no fórum Dúvidas
    Respostas: 2
    Último Post: 13-05-2013, 10:09 AM
  5. |Dúvida| Qual segurança usar em um server 97d ?
    Por William no fórum Flood Livre
    Respostas: 2
    Último Post: 13-05-2013, 10:09 AM

Marcadores

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •