Siga-nos em...
Follow us on Twitter Follow us on Facebook Watch us on YouTube
Registro

Alpha Servers
Resultados 1 a 9 de 9

Tópico: SQLAgent 2008

  1. #1

    Avatar de Poower_Mix
    Data de Ingresso
    Feb 2011
    Localização
    Bauru - SP
    Idade
    29
    Posts
    112
    Agradecido
    6
    Agradeceu
    6
    Peso da Avaliação
    10

    Padrão SQLAgent 2008

    Olá!

    Ymperianos, instalei o SQL Express 2008 em meu Cloud, após a instalação eu tentei iniciar o SQL Server Agent e não obtive sucesso com o mesmo, apareceu o seguinte aviso de erro:



    Alguém poderia me auxiliar com ajuda para resolver este problema, por favor?
    Desde já, obrigado!

    Att, Power.
    #MUTWIST - Fé em Deus!

    " Tudo posso naquele que me fortalece! "

  2. #2

    Avatar de lockzao
    Data de Ingresso
    Oct 2012
    Localização
    .
    Idade
    30
    Posts
    157
    Agradecido
    49
    Agradeceu
    38
    Peso da Avaliação
    9

    Padrão

    Primeiro passo: Executa esta query.

    Código:
    EXEC sp_configure 'show advanced options', 1;
    GO
    RECONFIGURE WITH OVERRIDE;
    GO
    EXEC sp_configure 'Agent XPs', 1;
    GO
    RECONFIGURE WITH OVERRIDE;
    GO
    EXEC sp_configure 'show advanced options', 0;
    GO
    RECONFIGURE WITH OVERRIDE;
    GO
    Segundo passo - Abra o SQL Server Management, seleciona SQL Server Agent, botão direito em cima, propriedades, conexão, se tiver algum alias remove deixa em branco e tenta startar o serviço novamente.

    Se não der certo, instala a edição enterprise, vai precisar fazer a mesma rotina.

    Att
    lockzao
    Última edição por lockzao; 31-05-2017 às 10:34 AM.

  3. #3

    Avatar de Poower_Mix
    Data de Ingresso
    Feb 2011
    Localização
    Bauru - SP
    Idade
    29
    Posts
    112
    Agradecido
    6
    Agradeceu
    6
    Peso da Avaliação
    10

    Padrão

    Citação Postado originalmente por lockzao Ver Post
    Primeiro passo: Executa esta query.

    Código:
    EXEC sp_configure 'show advanced options', 1;
    GO
    RECONFIGURE WITH OVERRIDE;
    GO
    EXEC sp_configure 'Agent XPs', 1;
    GO
    RECONFIGURE WITH OVERRIDE;
    GO
    EXEC sp_configure 'show advanced options', 0;
    GO
    RECONFIGURE WITH OVERRIDE;
    GO
    Segundo passo - Abra o SQL Server Management, seleciona SQL Server Agent, botão direito em cima, propriedades, conexão, se tiver algum alias remove deixa em branco e tenta startar o serviço novamente.

    Se não der certo, instala a edição enterprise, vai precisar fazer a mesma rotina.

    Att
    lockzao
    Amigo, o meu SQL Server Management não possui a parte do SQL Server Agent, de uma olhada
    Amigo, o meu SQL Server Management não possui a parte do SQL Server Agent, de uma olhada:
    #MUTWIST - Fé em Deus!

    " Tudo posso naquele que me fortalece! "

  4. #4

    Avatar de lockzao
    Data de Ingresso
    Oct 2012
    Localização
    .
    Idade
    30
    Posts
    157
    Agradecido
    49
    Agradeceu
    38
    Peso da Avaliação
    9

    Padrão

    Amigo, então instala o enterprise e saia da limitação o serial você pega no google agora o download segue ai o link [Somente usuários registrados podem vem os links. ] / [Somente usuários registrados podem vem os links. ]
    Última edição por lockzao; 31-05-2017 às 03:21 PM.

  5. O Seguinte Usuário Agradeceu lockzao Por este Post Útil:


  6. #5

    Avatar de Poower_Mix
    Data de Ingresso
    Feb 2011
    Localização
    Bauru - SP
    Idade
    29
    Posts
    112
    Agradecido
    6
    Agradeceu
    6
    Peso da Avaliação
    10

    Padrão

    Amigo, instalei aqui
    Problema resolvido.

    Muito obrigado, Att Power.

    ----------------------
    EDIT:
    Não estou consigo acessar meu banco de dados pela instância padrão, ex:
    MUTWIST\MSSQLSERVER
    Sómente por: (local)

    E também estou com erro de ODBC e ConectFail ao tentar ligar o servidor..
    Já criei a Fonte de Dados ODBC e o erro ainda persisti.

    Poderia me ajudar por favor?
    Última edição por Poower_Mix; 01-06-2017 às 02:01 PM.
    #MUTWIST - Fé em Deus!

    " Tudo posso naquele que me fortalece! "

  7. #6

    Avatar de lockzao
    Data de Ingresso
    Oct 2012
    Localização
    .
    Idade
    30
    Posts
    157
    Agradecido
    49
    Agradeceu
    38
    Peso da Avaliação
    9

    Padrão

    Citação Postado originalmente por Poower_Mix Ver Post

    EDIT:
    Não estou consigo acessar meu banco de dados pela instância padrão, ex:
    MUTWIST\MSSQSERVER
    Sómente por: (local)
    Normal, não tem problema eu também conecto por (local)

    - Não significa que irão invadir seu banco de dados.

    Citação Postado originalmente por Poower_Mix Ver Post
    [center]
    E também estou com erro de ODBC e ConectFail ao tentar ligar o servidor..
    Já criei a Fonte de Dados ODBC e o erro ainda persisti.
    - Com relação ao ODBC você deve instalar manualmente, vou enviar algumas ss para você seguir o passo a passo...
    - Os aplicativos para execução são em plataforma 32bits, no caso seu SO Windows Server deve ser 64bits, por tanto as ODBC devem ser criada para plataforma 32bits e não os drivers SQL Server como normalmente a gente ve por ai quando não é um SO Windows Server.

    Passo a passo:

    Vá em Ferramentas Administrativas -> Fontes de Dados ODBC (32 bits) -> DSN Sistema -> Olha quais as fontes que você tem que adicionar. -> Novamente nesta tela vá em adicionar -> Seleciona o Driver SQL Server Native Client 10.0 ou 11.0, de preferência 10.0 por que é o padrão da instalação, mas não tem problema em usar 11.0 -> Concluir -> Nome "Nome da fonte de dados que você anotou antes de apagar", "Nome da fonte de dados que você anotou antes de apagar", Servidor "(local)" -> Avançar -> Avançar -> Marca o checkbox e seleciona a base dados do seu muserver no caso como de costume "MuOnline" -> Avançar -> Concluir.

    Repete este passo a passo para cada nome de fonte que você for adicionar.

    Posta uns print ai para facilitar em te ajudar... precisar estamos ai...

    Gera um arquivo .reg com essas informações e testa, ve se da certo.

    Código:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\AccountDB]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="AccountDB"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\LocalServer]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="LocalServer"
    "Server"="(local)"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    "Database"="MuOnline"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\LOGIN]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="LOGIN"
    "Server"="(local)"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    "Database"="MuOnline"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\MuOnline]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="MuOnline"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\MuOnlineAdmin]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="MuOnlineAdmin"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\MuOnlineJoinDB]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="MuOnlineJoinDB"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\USELOG]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="USELOG"
    "Server"="(local)"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    "Database"="MuOnline"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\ODBC Data Sources]
    "AccountDB"="SQL Server Native Client 10.0"
    "LOGIN"="SQL Server Native Client 10.0"
    "LocalServer"="SQL Server Native Client 10.0"
    "MuOnline"="SQL Server Native Client 10.0"
    "MuOnlineAdmin"="SQL Server Native Client 10.0"
    "MuOnlineJoinDB"="SQL Server Native Client 10.0"
    "USELOG"="SQL Server Native Client 10.0"
    Att
    lockzao
    Última edição por lockzao; 01-06-2017 às 10:07 AM.

  8. O Seguinte Usuário Agradeceu lockzao Por este Post Útil:


  9. #7

    Avatar de Poower_Mix
    Data de Ingresso
    Feb 2011
    Localização
    Bauru - SP
    Idade
    29
    Posts
    112
    Agradecido
    6
    Agradeceu
    6
    Peso da Avaliação
    10

    Padrão

    Citação Postado originalmente por lockzao Ver Post
    Normal, não tem problema eu também conecto por (local)

    - Não significa que irão invadir seu banco de dados.



    - Com relação ao ODBC você deve instalar manualmente, vou enviar algumas ss para você seguir o passo a passo...
    - Os aplicativos para execução são em plataforma 32bits, no caso seu SO Windows Server deve ser 64bits, por tanto as ODBC devem ser criada para plataforma 32bits e não os drivers SQL Server como normalmente a gente ve por ai quando não é um SO Windows Server.

    Passo a passo:

    Vá em Ferramentas Administrativas -> Fontes de Dados ODBC (32 bits) -> DSN Sistema -> Olha quais as fontes que você tem que adicionar. -> Novamente nesta tela vá em adicionar -> Seleciona o Driver SQL Server Native Client 10.0 ou 11.0, de preferência 10.0 por que é o padrão da instalação, mas não tem problema em usar 11.0 -> Concluir -> Nome "Nome da fonte de dados que você anotou antes de apagar", "Nome da fonte de dados que você anotou antes de apagar", Servidor "(local)" -> Avançar -> Avançar -> Marca o checkbox e seleciona a base dados do seu muserver no caso como de costume "MuOnline" -> Avançar -> Concluir.

    Repete este passo a passo para cada nome de fonte que você for adicionar.

    Posta uns print ai para facilitar em te ajudar... precisar estamos ai...

    Gera um arquivo .reg com essas informações e testa, ve se da certo.

    Código:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\AccountDB]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="AccountDB"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\LocalServer]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="LocalServer"
    "Server"="(local)"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    "Database"="MuOnline"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\LOGIN]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="LOGIN"
    "Server"="(local)"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    "Database"="MuOnline"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\MuOnline]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="MuOnline"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\MuOnlineAdmin]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="MuOnlineAdmin"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\MuOnlineJoinDB]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="MuOnlineJoinDB"
    "Server"="(local)"
    "Database"="MuOnline"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\USELOG]
    "Driver"="C:\\Windows\\SysWOW64\\sqlncli10.dll"
    "Description"="USELOG"
    "Server"="(local)"
    "LastUser"="Administrator"
    "Trusted_Connection"="Yes"
    "Database"="MuOnline"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\ODBC Data Sources]
    "AccountDB"="SQL Server Native Client 10.0"
    "LOGIN"="SQL Server Native Client 10.0"
    "LocalServer"="SQL Server Native Client 10.0"
    "MuOnline"="SQL Server Native Client 10.0"
    "MuOnlineAdmin"="SQL Server Native Client 10.0"
    "MuOnlineJoinDB"="SQL Server Native Client 10.0"
    "USELOG"="SQL Server Native Client 10.0"
    Att
    lockzao
    Amigo, sobre a Fonte de dados ODBC, eu baixei uma na internet, executei e funcionou normalmente.. mas obrigado pela ajuda!
    Agora o problema é referente ao GAMESERVER que não está conseguindo conexão com o SQL, não sei o que colocar em "Host do SQL Server", já que a instância padrão não está funcionando (MUTWIST\MSSQLSERVER).
    Saberia me ajudar com este problema por favor?
    #MUTWIST - Fé em Deus!

    " Tudo posso naquele que me fortalece! "

  10. #8

    Avatar de lockzao
    Data de Ingresso
    Oct 2012
    Localização
    .
    Idade
    30
    Posts
    157
    Agradecido
    49
    Agradeceu
    38
    Peso da Avaliação
    9

    Padrão

    Citação Postado originalmente por Poower_Mix Ver Post


    Amigo, sobre a Fonte de dados ODBC, eu baixei uma na internet, executei e funcionou normalmente.. mas obrigado pela ajuda!
    Agora o problema é referente ao GAMESERVER que não está conseguindo conexão com o SQL, não sei o que colocar em "Host do SQL Server", já que a instância padrão não está funcionando (MUTWIST\MSSQLSERVER).
    Saberia me ajudar com este problema por favor?
    Como você instalou o express de inicio, recomendo desinstalar tudo e instalar do começo o enterprise que vai funcionar, não sei se você desinstalou a instalação do express, mas faça isso limpa qualquer vestígio da instalação do express e volta reinstalar o enterprise.

    Limpa tudo que tem de sql instalado e reinstala o enterprise... se possível depois da instalação remove até as pastas que ficam lá no C:\Program files... e reinstala novamente...

  11. O Seguinte Usuário Agradeceu lockzao Por este Post Útil:


  12. #9

    Avatar de Poower_Mix
    Data de Ingresso
    Feb 2011
    Localização
    Bauru - SP
    Idade
    29
    Posts
    112
    Agradecido
    6
    Agradeceu
    6
    Peso da Avaliação
    10

    Padrão

    Citação Postado originalmente por lockzao Ver Post
    Como você instalou o express de inicio, recomendo desinstalar tudo e instalar do começo o enterprise que vai funcionar, não sei se você desinstalou a instalação do express, mas faça isso limpa qualquer vestígio da instalação do express e volta reinstalar o enterprise.

    Limpa tudo que tem de sql instalado e reinstala o enterprise... se possível depois da instalação remove até as pastas que ficam lá no C:\Program files... e reinstala novamente...
    Já fiz isso amigo, removi o SQLExpress e todos os seus componentes, também exclui a pasta do SQL que tinha em Arquivos de Programas.
    Como eu especifiquei, coloquei o nome da instância padrão que foi instalada "MUTWIST\MSSQLSERVER" como Host do GS e não funcionou, também não consigo conectar no meu Banco de Dados do SQL com está instância padrão, sómente (local)
    Porém, o maior problema é com o GS
    Será que eu teria que formatar meu CLOUD e fazer o processo de instalação novamente do 0?

    ----------------
    EDIT
    O maior problema que preciso resolver é saber o que devo colocar em ''Host do SQL'' na parte de Config.ini do GAMESERVER para ele conectar com o SQL, já que a instância padrão não dá certo (MUTWIST\MSSQLSERVER).

    ---------------
    EDIT [2]
    Problema resolvido, era só colocar o IP no Config.ini do GS.
    Obrigado!

    Att, Power.
    Última edição por Poower_Mix; 01-06-2017 às 08:48 PM.
    #MUTWIST - Fé em Deus!

    " Tudo posso naquele que me fortalece! "

  13. O Seguinte Usuário Agradeceu Poower_Mix Por este Post Útil:


 

 

Informações de Tópico

Usuários Navegando neste Tópico

Há 1 usuários navegando neste tópico. (0 registrados e 1 visitantes)

Tópicos Similares

  1. |Dúvida| SQL 2008 + Apache
    Por CroSS_ADM no fórum Dúvidas
    Respostas: 0
    Último Post: 24-03-2016, 07:46 PM
  2. |Pedido| DB de mu pra sql 2008
    Por hadeslan no fórum Pedidos
    Respostas: 6
    Último Post: 30-06-2015, 06:00 AM
  3. |Pedido| SQL Server 2008
    Por danilodc no fórum Pedidos
    Respostas: 3
    Último Post: 19-10-2014, 02:08 AM
  4. |Dúvida| Mumaker e SQL 2008
    Por muagenew no fórum Dúvidas
    Respostas: 3
    Último Post: 24-07-2013, 03:25 PM
  5. |Source| Launcher VC++ 2008
    Por Chris7yan no fórum Sources
    Respostas: 0
    Último Post: 03-02-2010, 05:01 AM

Marcadores

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •